Daha çox

WPSClient və layer.events.on üçün OpenLayers sənədləri

WPSClient və layer.events.on üçün OpenLayers sənədləri


Aşağıdakı sənədləri tapmaqda çətinlik çəkirəm:

  • OpenLayers wpsclient sənədləri: məsələn: wpsclient JavaScript-in JTS-i çalıştırması üçün tələblər nədir: üst-üstə düşür və ya JTS: Fərq

    wpsClient.execute ({server: 'local', process: 'JTS: splitPolygon', // əgər bu başqa bir funksiya girişinə dəyişərsə: {polygon: mypolygon, // burada nə lazımdır ?? sətir: myline}
  • OpenLayers layer.events.on sənədləri ({… sketchcomplete və daha çox, amma nə olduqlarını və məlumatı harada tapacağımı bilmirəm).

Hansı seçimlər var? Bunu OpenLayers API sənədlərində tapa bilmirəm. Əminəm ki, burada aşkar bir şey itirirəm !! belədirsə üzr istəyirəm.


Birinci məqama cavab tapdım. Geoserver üçün bir sorğu istifadə. "Üst-üstə düşür" çıxdıqda bölmə aləti kimi "çoxbucaqlı" deyil, a: və b: girişi tələb olunur.

wpsClient.execute ({server: 'local', proses: 'JTS: üst-üstə düşür', // wps funksiyası girişləri: {a: mypolygon, // girişləri b: mypolygon}

Lazımi parametrləri necə tapmaq olar

Layer hadisələri ilə bağlı açıqlayanlar sənədləri üçün openlayers doc linkində tapdım


Videoya baxın: Imagine Dragons - Bad Liar RMV edit