Daha çox

QGIS tərəfindən istifadə olunan gdal-a qarşı ogrinfo-nu yenidən necə tərtib etmək olar?

QGIS tərəfindən istifadə olunan gdal-a qarşı ogrinfo-nu yenidən necə tərtib etmək olar?


Ubuntu-da qırılmış GDAL və PROJ.4-lərin təmirini həll etdim? istifadəsini bloklayanogrinfoogr2ogr, yalnız bu kommunalların bir şəkildə xarab olduğunu tapmaq üçün: bunlardan hər hansı birini işlədəndə aşağıdakı səhv olur (buogrinfoüçünogr2ogranaloqdur):

HATA 1: ogrinfo GDAL 1.9-a qarşı tərtib edilmişdir, lakin mövcud kitabxana versiyası 1.10

Səbəbini başa düşdüyümü düşünürəm: səhvən GDAL 1.9-u əl ilə quraşdırdımqurmaqburada təklif olunduğu kimi;silinbunun üçün mümkün deyil.OgrinfoGDAL-in bu versiyasına yığılmış və QGIS (2.10) ilə göndərilən 1.10 versiyasını unutmuşdur. Ancaq yenidən necə tərtib edəcəyim barədə heç bir fikrim olmadan burada qalmışamogrdoğru GDAL versiyasına qarşı.

Nə sınadım:

  • QGIS-i yenidən quraşdırın (iləsudo apt-get --purge autoremovesilindikdən sonra asılılıqları təmizləmək üçün)
  • zibilogrinfo,ogr2ogrvə hətta bütövdürGDAL-1.9qovluq; sonra bərpa etdimogrfaylları ancaq gdal 1.9 deyil, hər an edə bilərəm
  • kimi bir neçə seçim varsudo apt-get autoclean

Bəlkə də dəqiq adını bilsəydim ogr paketini təmizləmiş və qura bilərdim. Yoxsa köhnə versiyanı tamamilə təmizləməyim lazımdır və sonra bir şəkildə (necə?) QGIS yükləyicisinə ogr də quraşdırmasını söyləyim?


Bütün bunları axtardımgdalkompüterimdəki sənədlər və sənədlər olduğumu tapdıgdal-1.10in/ usr / bin /və olanlar üçün1.9in/ usr / local / bin /. Bütün 1.9 sənədləri əl ilə sildim - @evilGenius buna işarə etdi. İndi yalnız son addım var: sistemi ikili sistemə doğru yola yönəltmək. Kimi/ usr / bin / ogrinfomükəmməl işləyir.


Http://download.osgeo.org/gdal/1.10.1/ saytından GDAL 1.10 əldə edə bilərsiniz və 1.9 ilə olduğu kimi tərtib edə bilərsiniz.

BTW, GDAL 1.11.2, mövcud sabit versiyadır və QGIS-in vanil lubuntu 15.04-ə yüklənməsi həmin GDAL versiyasını ehtiva edir. Yəni silsəniz (öz-özünə tərtibatı silin vəsudo apt-get təmizlənməsibütün GDAL və QGIS məhsulları, sonra QGIS 2.10-u yenidən quraşdırın, siz də ona sahib olmalısınız.

Alternativ olaraq, http://packages.ubuntu.com/trusty/gdal-bin sizə doğru GDAL paketini verməlidir. Hesab edirəm ki, səhv (yəni işləyən) quraşdırmanı sildinizsudo apt-get kaldır gdal-bin.


Videoya baxın: Using a conditional statement to make a boolean layer in QGIS